Cut'n'paste problem, kinda

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
Post Reply
AlanStewart
Posts: 82
Joined: Fri Jun 02, 2006 6:52 pm

Cut'n'paste problem, kinda

Post by AlanStewart » Tue Mar 31, 2009 11:47 pm

This is for 3.96t-beta2.

Here's something that's a little vexxing. I sorta know *why* it's not behaving the way I want it to, but I'm kinda thinking that it *should* behave the way I want it to?

Given these two lines of code

Code: Select all

//      ,java.util.none
      ,gnu.io.UnsupportedCommOperationException
if I cut the second line and immediately paste it back in, it doesn't come back exactly the same. All the leading spaces are trimmed so that things line up with the immediately previous, commented out line of code. Which isn't what I want. Since I'm pasting the line in, it should go back in exactly as it was, spaces and all.

I know this has to do with the whole "auto-format" stuff. Maybe there's an option I need to tweak?

Thanks,
Alan

P.S. Okay, how come phpbb is messin' wit ma code?? It's converting "Too Many Listeners Exception" to "none". WTF?

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Wed Apr 01, 2009 3:01 am

if I cut the second line and immediately paste it back in, it doesn't come back exactly the same. All the leading spaces are trimmed so that things line up with the immediately previous
This is not a bug ;)

To change this behaviour, use the Options, Editor Options menu, go to the Keyboard Mapping panel and remap the paste key from MarkPasteSmart to MarkPasteEx function.

This special pasting is done by the MarkPasteSmart function ;)

Cheers Jussi

AlanStewart
Posts: 82
Joined: Fri Jun 02, 2006 6:52 pm

Post by AlanStewart » Sun Apr 05, 2009 5:39 am

Found it. Fixed it. Me happy now!

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: No registered users and 3 guests