right click on commented code kill Zeus

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
Post Reply
JackR
Posts: 61
Joined: Fri Jun 16, 2006 8:50 pm

right click on commented code kill Zeus

Post by JackR » Wed Nov 19, 2008 10:09 pm

Hi Jussi

I have been using 3.96r for about 2 weeks. I just noticed this bug, but it is very repeatable on my system ( win2K if it matters). This bug causes zeus to hang up. It becomes non-responsive. Windows reports zeus as not responding. If I attempt to force a close from task manager, I get a message that the program is being debugged and can't be closed

To recreate this condition:
1) open a cpp file from the project navigator
2) select a few lines of code which are commented out. below are the lines of code I have. I do a column select so only a few columns in these 3 rows are selected ( I don't think this last detail matters)

// my_states[OVERALL].init( NULL, NULL, NULL);
// my_states[OVERALL].make_transition(
// sm.initialize_appl_state_machine( my_states, NUM_STATES, this, OVERALL );

4) Right click the mouse. Zeus is now dead.


Jack

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Wed Nov 19, 2008 11:09 pm

Hi Jack,

Unfortunately I can not replicate the bug :(

I suspect it is probably configuration related :?

Could you zip up you zConfig folder and send it to me as an e-mail attachment.

Also if you could send a simple file that shows the error and a screen shot of the problem that would be great ;)

Thanks Jussi

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Tue Dec 09, 2008 10:53 pm

Hi Jack,

Unfortunately I was not able to replicate this bug :(

All I can suggest is renaming your current Zeus install directory and then running the latest Zeus installer found here:

http://www.zeusedit.com/download.html

If this fixes the problem, just copy over the zConfig folder from the old installation.

Cheers Jussi

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Mon Feb 16, 2009 11:16 pm

Unfortunately I am still not able to replicate this bug :(

But if you are still having this issue could you try the latest patch found here:

http://www.zeusedit.com/forum/viewforum.php?f=6

Cheers Jussi

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: No registered users and 5 guests