Set "File of type"

Find Tips and tricks on how to better use the Zeus IDE. Feel free to post your own tips but please do not post bug reports, feature requests or questions here.
Post Reply
ordba
Posts: 6
Joined: Fri Aug 27, 2004 12:44 pm

Set "File of type"

Post by ordba »

I can't recall what I did to set this but when I "Open File" my
"Files of type" looks like this: All Files (*.*).
All the files in the directory are displayed. When I go to Options and open Document types I don't see anything in there that looks like "All Files (*.*)".

What did I do to get this functionality? I just can't recall.
I need to duplicate this functionlity.
Your assistance will be greatly appreciated.
jussij
Site Admin
Posts: 2476
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij »

I can't recall what I did to set this but when I "Open File" my "Files of type" looks like this: All Files (*.*).
This is how the File Open dialog works in Zeus.

In the General section of the Document Type there is the Display these file in the File Open types list option.

With this option checked the file extensions of that document type will get added as a filter type to the file open dialog type list.

So when you open a file Zeus goes through all the document types and adds a file type to the list of types for all document types that have this option checked. It also adds the default *.* filter.

Zeus also automatically selects the filter type that matches the filter type of the currently active document or the *.* filter type if no files are open.

To disable the automatic file filtering use the Options, Editor Options menu and in the General section turn off the Enable file type fitering option.

Cheers Jussi
Post Reply