Opening file with UTF-8 encoded name from Explorer fails

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
Post Reply
kleist
Posts: 22
Joined: Tue Jan 11, 2011 6:20 pm

Opening file with UTF-8 encoded name from Explorer fails

Post by kleist » Tue Mar 29, 2011 8:37 pm

[Zeus 3.97e / Windows 7 SP1 64 bit]

Trying to open a file with a UTF-8 encoded name (like "räksmörgås.txt") from the Windows Explorer fails. The same if a file with an ascii name resides in a directory with a UTF-8 encoded name.

If the file is simply (double)clicked, nothing happens, i.e. no error message appears.

If I choose "Open with" from the context menu, and then "Programmer's Editor for Windows", the error message "There was a problem sending the command to the program." is displayed in a window.

Opening the file with Notpad or Textpad works fine.

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Tue Mar 29, 2011 11:09 pm

Unfortunately I was not able to replicate this issue :(

But I am running a Win32 bit version of Windows which might be part of the problem.

What I did was start Explorer and used it to create a new file in the temp folder location with this name: räksmörgås.txt

Now from inside Explorer I can drag and drop the file, Open With and I double click on the file and in all cases the file opens just fine in Zeus :?

Could you send me an example file as an e-mail attachement :?:

What is interesting is if I do a dir räksmörgås.txt inside of Zeus I see this:

Code: Select all

Directory of C:\temp

30/03/2011  09:56 AM                11 r„ksm”rg†s.txt
But if I run the same command from the command prompt I see the correct name:

Code: Select all

Directory of c:\temp

30/03/2011  09:56 AM                11 räksmörgås.txt
I suspect this is due to a bug in the Zeus tool capture output code :(

Cheers Jussi

kleist
Posts: 22
Joined: Tue Jan 11, 2011 6:20 pm

Post by kleist » Thu Mar 31, 2011 8:07 am

Hello again Jussi,

I've found something pretty odd...

If I start Zeus, and after that chose "Open with..." / "Programmer's Editor for Windows" from the file's context menu in Explorer, then the file opens fine :!:

Not if I (double)click on the file though.

Drag-and-drop to the Zeus window works fine.

Drag-and-drop to my Zeus shortcut icon on the desktop doesn't work.

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Thu Mar 31, 2011 11:10 pm

Not if I (double)click on the file though.

This seems to suggest that there is something wrong with the ZeusDocument registry setting :?

In the registry the ZeusDocument is defined here:

Code: Select all

HKEY_CLASSES_ROOT\ZeusDocument\shell\open\command
and it should be defined with this default value:

Code: Select all

"C:\Program Files\Zeus\zeus.exe" "%1"
What you could try is changing the command line to be:

Code: Select all

"C:\Program Files\Zeus\zeus.exe" '%1'
For the file type that fails to load on double click, did you associate the file with Zeus or was it one of the predefined Zeus association :?:

Cheers Jussi

kleist
Posts: 22
Joined: Tue Jan 11, 2011 6:20 pm

Post by kleist » Tue Apr 26, 2011 3:20 pm

Sorry for not having replied until now, Jussi.

I've verified the registry setting for "HKEY_CLASSES_ROOT\ZeusDocument\shell\open\command".

Changing the double quotes round %1 to single quotes makes no difference.

:shock: When opening the file with an already running Zeus using "Open with... " from the context menu, those single quotes are changed back to double quotes. :shock:

The problem appears both for predefined Zeus associations (like *.txt) and associations made by me (*.acl).

All in all: This is a very minor problem, since Zeus is typically running all the time on my 'puter. And I seldom edit files with non-ascii names.

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: No registered users and 25 guests