Windows clipboard problem: UTF-8 - ANSI

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
Post Reply
petar12345
Posts: 26
Joined: Tue May 08, 2007 7:05 pm

Windows clipboard problem: UTF-8 - ANSI

Post by petar12345 » Tue Sep 07, 2010 11:30 am

Example 1:
1.1. In zeus: make new document (Zeus menu: File->New)
1.2. In zeus: type these two lines in it:
I use "Courier New CE" font in Zeus.
These are Croatians leters: Upper case: ČĆĐŠŽ lower case: čćđšž.
1.3. In zeus: Mark all text in this new file (Ctrl+A)
1.4. In zeus: Copy marked text to clipboard (Ctrl+C)

1.5. Open windows notepad
1.6. In notepad: paste text from clipboard. (Ctrl+V)
1.7. In notepad: File->Save As: test1.txt

1.8. In zeus: File->Open: test1.txt.

Everything is ok in test1.txt.
File is ANSI and Croatian leters are ok.


Example 2:

2.1. Open windows notepad
2.2. In notepad: File->Open: test1.txt. (test1.txt - from example 1)
2.3. In notepad: Mark all text in this file (Ctrl+A)
2.4. In notepad: Copy marked text to clipboard (Ctrl+C)
2.5. In zeus: make new document (Zeus menu: File->New)
2.6. In zeus: paste text from clipboard. (Ctrl+V)

Croatian leters are there, but file is UTF-8.
If I save this file with option ANSI, I lose croatian leters.


Why its happening? Where is the problem?
Is there a solution?

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Mon Nov 15, 2010 11:04 pm

This clipboard bug should be fixed in the current beta release: http://www.zeusedit.com/z300/ze397d-beta.zip

Cheers Jussi

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: No registered users and 27 guests