Compiler error window doesn't work consistently

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
Post Reply
Jack Rosenbloom

Compiler error window doesn't work consistently

Post by Jack Rosenbloom » Fri Nov 05, 2004 6:49 pm

First of all, great product. I've been using the evalution version with the open watcom compiler for a few days. Expect an order for 3 copies next week. Now for my problem:

After I complete a make, a project make window is created with the compiler output. Sometimes, double clicking on a warning or error opens the source window and sometimes it doesn't. Whether it does or not, the error or warning is always displayed on the status line(bottom of display). Errors are displayed in red in the Build output window so I assume the editor is able to parse the compiler output.

One more strange symptom with this. Of the 16 cpp files in this project, some can always automatically be found from the compiler output window. Most only work sometimes.

Any ideas? I there anything I can send you from my build or environment?

Jack

jussij
Site Admin
Posts: 2431
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Sat Nov 06, 2004 1:53 pm

Hi Jack,
After I complete a make, a project make window is created with the compiler output. Sometimes, double clicking on a warning or error opens the source window and sometimes it doesn't. Whether it does or not, the error or warning is always displayed on the status line(bottom of display). Errors are displayed in red in the Build output window so I assume the editor is able to parse the compiler output.
To better understand what might be going wrong, here is some background into how the output is managed.

Zeus uses a number of regular expressions to parse compiler output. These regular expressions are defined in the General section of the Document Type or the General section of the Project/Worskpace and when no regular expressions are defined, Zeus uses built-in defaults.

The fact that the errors are displayed in red means the errors regular expresion is correct. The files regular expression is used to locate the file name from the line of compiler output and from what you describe, it might be this regexp that is causing the.

But since something is displayed in the status bar, I think Zeus is finding a file name. I suspect the file name in the compiler output is not fully qualified and this is the reason Zeus fails to load the file.

If this is the case you need to help Zeus locate the file by defining a search path. You can define a search path within the Document Type or the General section of the Project/Worskpace.

To define a search path just define any set of semi-colon delimited directories for example:

Code: Select all

c:\temp;c:\program files\zeus;c:\program files\zeus\zexample;
Depending on your project directory structure you might also get away with defining a Zeus workspace. Zeus automatically use the current workspace as the default search path. But this feature will not help if the source files are held in sub directories off the main project directory?

Code: Select all

One more strange symptom with this. Of the 16 cpp files in this project, some can always automatically be found from the compiler output window. Most only work sometimes.
If you find this information does not fix the problem, post the text of the project output window, the Zeus status message and a description of the directory structure of a file that does not load. With this additional information it should be possible to come up with configuration setting that will make this work.

Cheers Jussi

Guest

Post by Guest » Mon Nov 08, 2004 6:49 pm

I was navigating between different projects and directories which I guess can explain why it worked sometime and not other times. Since all my source files are in one directory, I added a search path to my projects and so far, all is working fine. I'll assume that was the problem for now.

Guest

Post by Guest » Mon Nov 08, 2004 7:30 pm

As soon do I say all is well, the problem is back. Below in the info I believe you requested. The problem return after I changed to 2 other workspaces and then back to the original. Sometimes I closed the current workspace, sometime I just opened a new one ( assuming an auto close occurs)


*** OUTPUT FILE ****
---------------------------------------------------------------------------
Zeus for Windows Programmers Editor - Version 3.93d
Copyright (c) Xidicone Pty Ltd 1993-2004. All rights reserved.
---------------------------------------------------------------------------
**** Unregistered Software. To be used for evaluation purposes only. ****
---------------------------------------------------------------------------

Debug: Changed to the 'C:\projects\watcom\src\' directory supplied
Debug: Command: wmake -a -f makefile.mk1 TARGET=__RUN_ON_PC__
--------------------Configuration: 1_runonpc - Debug--------------------
Debug: Command Line: C:\WINNT\system32\cmd.exe /c wmake -a -f makefile.mk1 TARGET=__RUN_ON_PC__
Debug: Started Process ID: 0x744

Open Watcom Make Version 1.3
Portions Copyright (c) 1988-2002 Sybase, Inc. All Rights Reserved.
Source code is available under the Sybase Open Watcom Public License.
See http://www.openwatcom.org/ for details.
"------FILE------" debug.cpp
"------FILE------" appl.cpp
"------FILE------" init.cpp
init.cpp(58): Warning! W726: col(1) no reference to formal parameter 'argc'
init.cpp(56): Note! N392: col(25) definition: 'int argc' in 'void ini_file_init( int, char * * )'
init.cpp(58): Warning! W726: col(1) no reference to formal parameter 'argv'
init.cpp(56): Note! N392: col(37) definition: 'char * * argv' in 'void ini_file_init( int, char * * )'
"Compile Complete: Linking..."
"Build Successfully Completed"
********* END OF OUTPUT FILE **************

If I double click on either line which contains the warning, the status line contains the exact information as the line I clicked on but the file init.cpp never opens. This init.cpp is in the same directory as all the other source.

All source code is in the directory
c:\projects\watcom\src

If it matters, object code is in the directory
c:\projects\watcom\src\pc_obj

The tool called current directory displays

****** BEGINNING LINES REMOVED BY ME ******

Directory of C:\projects\watcom\src

11/08/2004 02:21p <DIR> .
11/08/2004 02:21p <DIR> ..
11/08/2004 02:15p 2,938 1_Build.zpi
11/08/2004 02:15p 3,215 1_runonpc.zpi
11/08/2004 02:21p 1,499 1_runonpc.zpi.z
11/08/2004 02:15p 3,032 2_debug.zpi
11/08/2004 02:15p 3,033 3_target.zpi
11/08/2004 01:19p 16,468 appl.cpp
06/18/2004 03:23p 2,141 bat_ram.h
07/24/2003 06:10a 47,584 CAPI.C
11/08/2004 10:25a 1,164 debug.cpp
06/15/2004 10:46a 2,174 init.cpp
11/08/2004 02:21p 357 init.err
10/12/2004 01:21p 1,319 init.h
11/08/2004 10:18a 1,076 makefile.mk1
11/08/2004 10:38a <DIR> pc_obj
11/08/2004 02:15p 541 project.ini
11/08/2004 01:19p 5,084 project.zbi
11/08/2004 02:15p 3,201 project.zpi
11/08/2004 02:15p 457 project.zwi
11/08/2004 02:21p 96,809 runonpc.exe
11/08/2004 02:21p 20,226 runonpc.map
11/08/2004 10:36a 74,316 urc.zbi
11/08/2004 02:15p 5,021 urc.zpi
07/24/2003 06:10a 9,919 _capi.c
22 File(s) 301,574 bytes
3 Dir(s) 66,827,622,912 bytes free

Jack Rosenbloom

Post by Jack Rosenbloom » Mon Nov 08, 2004 7:33 pm

The faces in my previous msg are actually 8)

example:
init.cpp(58): Warning! W726: col(1) no reference to formal parameter 'argc'

I forgot to turn the faces off

Jack

jussij
Site Admin
Posts: 2431
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Mon Nov 08, 2004 11:58 pm

Hi Jack,

I used your output details, file directory structure and a copy of the Zeus 3.93d shareware to recreate your project/workspace structure. But unfortunately for me the file loading worked worked just fine :(

So could you please try the following:

(1) With the project output window showing highlight the following text:

init.cpp(58)

and use the View, Open Include menu. This command should either load the file or report an error in the status bar. If it reports an error please make a note of the text and post it here. If it loads the file then I really don't know why the double click is not also loading the file :(

(2) Also, just to be sure it is not a search path issuse, in your 1_runonpc workspace go to the Workspace, Options, General panel and in the Search path edit field add the c:\projects\watchom\src; text.

(3) With the Project Output window showing place the cursor on the init.cpp line of error output and use the right mouse click to bring up the popup menu. Does the second item in the popup menu say the following:

Open 'init.cpp' Include File

If it does then the regular expression has found the file name from the line of output and the search path must be the reason the file is not loading.

If the problem persists could you please re-run the 1_runonpc build and put:

c:\projects\watchom\src\*.zerr
c:\projects\watchom\src\*.zwi
c:\projects\watchom\src\*.zpi

into a zip file with the Save extra folder information option enabled and send it to support@zeusedit.com with the subject of Zeus Project Bug. Note that you do not need to send me the source files.

With this information I will once again try to recreate the error.

Cheers Jussi

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: No registered users and 3 guests