Error updating Document List on multi-file save

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
Post Reply
AlanStewart
Posts: 82
Joined: Fri Jun 02, 2006 6:52 pm

Error updating Document List on multi-file save

Post by AlanStewart » Thu Nov 26, 2009 10:43 pm

Hello.

I've found a little interesting bug in my copy Zeus 3.97. I edited a bunch of files and when I brought up the Document List (Alt-V for me) the Status column was all '*'s, to indicate that there are unsaved changes. This is cool. This is *GOOD* UI!

Then I highlighted all the changed files and did Alt-S to save them all. All the '*'s disappeared (as expected) but so did the Encoding column for all my files (ASCII and UTF-8, nothing fancy there).

In fact, I just checked it now and even if a file hasn't been changed (no '*') and I do Alt-S then the Encoding disappears and the [Save] button is greyed out.

Closing the Document List window and re-opening it brings everything back as normal.

Just thought I'd mention it.

Alan Stewart

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Thu Nov 26, 2009 11:42 pm

Hi Alan,

Thanks for the bug report. I have managed to replicate the bug so it will be fixed in the next patch ;)

Cheers Jussi

AlanStewart
Posts: 82
Joined: Fri Jun 02, 2006 6:52 pm

Post by AlanStewart » Fri Nov 27, 2009 12:04 am

Excellent! I'm just surprised that I never noticed this before now!

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Fri Nov 27, 2009 12:46 am

I never noticed this before now!
The Encoding column was added in version 3.97 and it is this change that introduced the bug :(

What s going on is when the file is saved the Status column is reset by blanking out the text found at column four. But because the Encoding column was added the Status column is no longer at column location four ;)

Cheers Jussi

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Mon Dec 14, 2009 1:38 am

This bug has been fixed in the latest release found here: http://www.zeusedit.com/forum/viewtopic.php?p=5306

Cheers Jussi

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: No registered users and 29 guests