Page 1 of 1

Zeus 3.97

Posted: Mon Jul 06, 2009 4:55 pm
by mgag
When I try to run Zeus 3.97, I get a message box with,

This application has failed to start becasue the application configuration is incorrect. Reinstalling the application may fix this problem.

I was able to get the full install to work - but I lost all my settings.

Zeus 397 mark copy past problem

Posted: Mon Jul 06, 2009 6:48 pm
by petar12345
I have program in font: Curier New CE, Language: Easteurope
with croatian alpha character and printer box character.
Oem file translation: No Oem translation
I was mark all text, and copy it to end of file. Result is :shock: :?:
Pasted code is not equal like orginal code, and ther are first 3 nonvisible character in file EF BB BF.

Program:
----------------
Cro:
ASCII Š Đ Č Ć Ž š đ č ć ž
HEX 8A D0 C8 C6 8E 9A F0 E8 E6 9E

Line and box codes for printers:
ASCII Ú Â ż ł Ă Ĺ Ä ´ Ŕ Á Ů
HEX DA C2 BF B3 C3 C5 C4 B4 C0 C1 D9

first_name = "Štefica"
Last_name = "Đačić"

AADD(head, "ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÂÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄż")
AADD(head, "łfirst_name ł Last_name ł")
AADD(head, "ŔÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÁÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄŮ")
// Štefica Đačić



Program after mark all - paste:
----------------
Cro:
ASCII Š Đ Č Ć Ž š đ č ć ž
HEX 8A D0 C8 C6 8E 9A F0 E8 E6 9E

Line and box codes for printers:
ASCII Ú Â ż ł Ă Ĺ Ä ´ Ŕ Á Ů
HEX DA C2 BF B3 C3 C5 C4 B4 C0 C1 D9

first_name = "Štefica"
Last_name = "Đačić"

AADD(head, "ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÂÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄż")
AADD(head, "łfirst_name ł Last_name ł")
AADD(head, "ŔÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÁÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄŮ")
// Štefica Đačić
font: Curier New CE, Language: Easteurope
----------------
Cro:
ASCII Ĺ  Ä￾ ÄŚ Ć Ĺ˝ š Ä‘ ÄŤ ć Ĺľ
HEX 8A D0 C8 C6 8E 9A F0 E8 E6 9E

Line and box codes for printers:
ASCII Ăš Ă‚ ĹĽ Ĺ‚ Ä‚ Äą Ă„ ´ Ĺ” Ă￾ Ĺ®
HEX DA C2 BF B3 C3 C5 C4 B4 C0 C1 D9

first_name = "Ĺ tefica"
Last_name = "Ä￾aÄŤić"

AADD(head, "ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÂÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄż")
AADD(head, "Ĺ‚first_name Ĺ‚ Last_name Ĺ‚")
AADD(head, "ŔÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄĂ￾Ă„Ă„Ă„Ă„Ă„Ă„Ă„Ă„Ă„Ă„Ă„Ă„Ă„Ă„Ă„Ă„Ĺ®")
// Ĺ tefica Ä￾aÄŤić

Posted: Mon Jul 06, 2009 10:05 pm
by jussij
Hi Petar,
have program in font: Curier New CE, Language: Easteurope
with croatian alpha character and printer box character.
The latest version of Zeus is UTF8/Unicode enabled.

It looks like the text that you copied to the clipboard contained a UTF8 character, so Zeus would have added the text to the clipboard as Unicode.

When this text is pasted it back into Zeus, it is detected as Unicode and hence Zeus will flag the file as a UTF8 file type.

The type of file that Zeus is detects is shown in the status bar.

So is the file you are editing a UTF8 file :?:
Pasted code is not equal like orginal code, and ther are first 3 nonvisible character in file EF BB BF.
These characters are the UTF8 BOM header. In there Save As dialog there is an option to add the BOM header to the file.

Cheers Jussi

Posted: Mon Jul 06, 2009 10:38 pm
by jussij
Hi Petar,

I had a look at you files and I suspect the box drawing characters that are in the file are probably causing the problem :(

They are probably being detected as UTF8, but I will have to see if this is the case :?

What Zeus OEM setting do you normally use :?:

Also what happens if you do a file Save As and return the file format back to the ASCII file type :?:

Cheers Jussi

Posted: Tue Jul 07, 2009 5:58 am
by petar12345
jussij wrote: What Zeus OEM setting do you normally use :?:

Also what happens if you do a file Save As and return the file format back to the ASCII file type :?:

Cheers Jussi
I use: No Oem translation. I send to You may zConfig files by mail.

Posted: Tue Jul 07, 2009 6:24 am
by petar12345
jussij wrote: Also what happens if you do a file Save As and return the file format back to the ASCII file type :?:
When I do it, orginal lines in file are Ok, pasted lines are in UTF-8 and are
not like orginal lines.

Posted: Tue Jul 07, 2009 6:59 am
by jussij
The issue is caused by the fact that the line of being copied to the clipboard contains UTF8 characters :(

Zeus puts the text into the clipboard as CF_TEXT format but Windows in it's wisdom then adds an extra Unicode version of that text to the clipboard :x

Now when the text is pasted back into Zeus, it finds the Unicode version put there by Windows and it uses that text in the paste operation.

But because the text being pasted back is recognised as Unicode, Zeus then changes the file format from it's original ASCII to UTF/8Unicode and this is what is causing the problem :(

Cheers Jussi

Posted: Tue Jul 07, 2009 7:38 am
by petar12345
Hi
jussij wrote:The issue is caused by the fact that the line of being copied to the clipboard contains UTF8 characters :(

Zeus puts the text into the clipboard as CF_TEXT format but Windows in it's wisdom then adds an extra Unicode version of that text to the clipboard :x

Now when the text is pasted back into Zeus, it finds the Unicode version put there by Windows and it uses that text in the paste operation.

But because the text being pasted back is recognised as Unicode, Zeus then changes the file format from it's original ASCII to UTF/8Unicode and this is what is causing the problem :(

Cheers Jussi

What is solution? Zeus 3.96q on same PC, with same Windows Xp pro, with same clipboard past box, and croatian characters with no changes.
Do I must stay on version 3.96q?

Posted: Tue Jul 07, 2009 8:50 am
by jussij
What is solution?
I will send you a beta version that should hopefully work around this problem ;)

Cheers Jussi

Posted: Tue Jul 07, 2009 8:54 am
by petar12345
jussij wrote: I will send you a beta version that should hopefully work around this problem ;)

Cheers Jussi
Thank you.

Posted: Tue Jul 07, 2009 7:28 pm
by petar12345
jussij wrote: Here is a new Zeus beta that should fix the copy
and paste bug that you reported:
http://www.zeusedit.com/z300/ze397-beta.zip
It is it.

Thank you. :D

Posted: Wed Jul 08, 2009 1:07 am
by jussij
It is nice summer in Croatia.

It looks very nice in Croatia :)

It is winter here in Sydney and today it is cold and wet :(

Cheers Jussi

Posted: Wed Jul 08, 2009 6:58 pm
by petar12345
Hi.

I have next question.
In my windows setings keyboard language is Croatian.
This is list of character I must type with Ctrl+Alt+|key|:
\ Ctrl+Alt+Q
| Ctrl+Alt+W
[ Ctrl+Alt+F
] Ctrl+Alt+G
@ Ctrl+Alt+V
{ Ctrl+Alt+B
} Ctrl+Alt+N
~ Ctrl+Alt+1

In Zeus 3.97a - beta if I press any of this key combination, beep occure and character is not inserted in editing file.
I tray type same in windows notepad. In notepad is ok. In Zeus in dialog box Search, Search-Replace is ok. Only, I can not type it in editing file.

I can copy - past any character what I need.
In zeus 3.96q, my keyboard was work just fine.
Can you see sometimes wath occur.

By.

Posted: Thu Jul 09, 2009 1:41 am
by jussij
In Zeus 3.97a - beta if I press any of this key combination, beep occure and character is not inserted in editing file.

Use the Options, Editor Options menu and in the General panel make sure the Display Alt key codes and Display Ctrl key codes option are checked.

Cheers Jussi

Posted: Thu Jul 09, 2009 12:00 pm
by petar12345
Hi.
jussij wrote:Use the Options, Editor Options menu and in the General panel make sure the Display Alt key codes and Display Ctrl key codes option are checked.
Cheers Jussi
Yes, this setings I was change when have problem: UTF8 mark - paste.

Thank You for help.
By.