xtags problem

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
wraith808
Posts: 8
Joined: Fri Apr 24, 2009 5:47 pm

Post by wraith808 » Mon Apr 27, 2009 4:28 pm

I had the same problem described here, and have followed all the steps. Then I made a new project, and the problem apparently went away, but I can't find any tags in the new database. What could I be doing wrong?

jussij
Site Admin
Posts: 2449
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Mon Apr 27, 2009 11:52 pm

but I can't find any tags in the new database. What could I be doing wrong?
The tags database file is named project.zbd where project is the name of the project. The details contained in the class browser panel represent the contents of this database file.

The contents of this database represent the tag information produced by ctags and these are the languages that ctags supports:

http://ctags.sourceforge.net/languages.html

So if you are saying the class browser panel is empty it probably means ctags didn't generate any tags information from your source code.

You can check this by turning on debugging via the xtags.ini file:

Code: Select all

[xTags]
Arguments=--c-types=+fp --excmd=p --fields=+afmikKlnsSz --sort=no
Debug=1
With this flag enabled Zeus will not delete the tag files generated by ctags so you can open the file to see if any tag information was created.

Cheers Jussi

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: No registered users and 21 guests