File New causes error message

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
Post Reply
banjo

File New causes error message

Post by banjo »

Hello,

I am using Version 3.94A. When I select "File" "New", I get the following error message.
Error opening:'v' Reason: \??

With a Hex Editor, these last two characters are "F9" and "81".

The text appears in the body of the new document. I can delete this text and save the file normally. Yet every time I try to create a new file this way I get a similar error message.

What am I doing wrong?

Thanks.

---- Steve
jussij
Site Admin
Posts: 2461
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij »

Let me get straight, if you hit the File, New menu you get an error message. That is very strange indeed :?

I can understand the strangeness of the Error opening:'v' Reason: \?? message as I think this problem was due to a badly formated error message, but what I don't understand is why there is an error in the first place :?:

All I can suggest is make sure the File, New Template option found in the Document Type of the new file created is empty.

Jussi
jussij
Site Admin
Posts: 2461
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij »

I had a look at the source code and it does look like the error message is caused by a missing template file. To fix this problem create a new document, use the Options, Properties menu and remove the File New Template entry from the Document Type.

Jussi
Guest

Nothing in the Template string??

Post by Guest »

I looked for this template option. However, the entry I found under Options, Properties, General is blank. The text box contains no characters at all. I modified another field and saved to force an update, yet the problem remains.
The "v" that the error message is reporting is suspicious, as I attempted in my clunky way to configure the editor for Verilog, whose file extension is "v". I suspect I managed to mangle something there that is now spilling over into all other file types. However, I am at al loss as to what I messed up.
jussij
Site Admin
Posts: 2461
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij »

You could try going to the zConfig directory and renaming the ZeusV-general.ext to somehting like ZeusV-general.ext_old and see if that changes anything.

Also using the Options, Editor Options menu, in the General section try changing the Default File New to anything other than the current extension given to a new file.

Cheers Jussi
banjo

Post by banjo »

Renaming the Zeusv-general.ext did not change anything. If I am in a .c file and choose file --> new I still get the error. If I open the Options-->Properties-->General and change the File New Template from nothing to "foo" I then get an error message about error opening 'foo' rather that 'v'.
Therefore, it seems that some global template option is somewhere set to 'v' and is overiding all cases where a local template option is not set.
It is not a fatal problem. I can just delete the error text from the first line of the new file and continue as normal.

---- Steve
Post Reply