New file Save as Url

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
Post Reply

New file Save as Url

Post by Guest » Wed Jun 01, 2005 9:03 pm

In the latest version if Zeus, when I create a new file then select File->Save as URL, and save to a directory on one of my pre configured hosts, Zeus will crash.

I've confirmed this happens on more then just my machine.

Zeus does not seem to have a problem saving to a file that already exists, only when I am trying to save a new file onto the ftp host.

Site Admin
Posts: 2451
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Wed Jun 01, 2005 11:28 pm

Thank you for the bug report. This should be an easy bug to fix, so it should be fixed in the next release.


Site Admin
Posts: 2451
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Thu Jun 02, 2005 10:38 am

Unfortunately I was not able to replicate this crash :( By creating a new file and using the File, Save as URL menu I was able to save this file to the Zeus ftp server.

I also repeated the test with debugging enabled (ie using the Options Editor Options menu and enabling the help debug tools and macros option) which resulted in the following information being logged in the Macro Debug window:

Code: Select all

Connected to Server(
Protocol(FTP) Port(21) User(testing) [Password supplied]
Resolving server name....
Name resolved.
Connecting to server....
220 ProFTPD FTP Server ready.
Connected to server.
USER testing
331 Password required for jussij.
PASS supplied.
230 User testing logged in.
215 UNIX Type: L8
CWD /mainwebsite_html
250 CWD command successful.
PORT 210,50,16,187,4,168
200 PORT command successful
150 Opening ASCII mode data connection for file list
drwxr-xr-x   2 admin   admin       4096 Nov 18  2003 admin
drwxr-xr-x   6 admin   admin       4096 Feb 16  2004 archives
.......... snip long file list .............
226 Transfer complete.
Putting file: 'C:\TEMP\ftp10.tmp' to '/mainwebsite_html/test_file.txt'
Sending request....
Sending request....
200 Type set to I.
PORT 210,50,16,187,4,169
200 PORT command successful
STOR /mainwebsite_html/test_file.txt
150 Opening BINARY mode data connection for /mainwebsite_html/test_file.txt
File transfer complete.
226 Transfer complete.
221 Goodbye.
So for me the save as URL worked just fine :?

Can you tell me which version of Zeus are you running?

If you repeat the test above, at what point in the file save as does Zeus crash?

Cheers Jussi

Posts: 6
Joined: Wed Jun 01, 2005 8:58 pm

Post by ntitan » Thu Jun 02, 2005 3:51 pm


I'm running version 3.94a

I have 'help debug tools and macros' checked under the general tab, but I'm not getting debug like yours, is there something else I need to do?


Here is some output from the ZeusErr.log when it crashes:

Code: Select all

Zeus for Windows Version 3.94a  Xidicone Pty Ltd  Copyright (c)  1993-2005
Exception code: C00000FD STACK_OVERFLOW
Date: Thu Jun 02 09:45:47 2005

Fault address:  7C809752 01:00008752 C:\WINDOWS\system32\kernel32.dll

SS:ESP:0023:00033000  EBP:00033014
DS:0023  ES:0023  FS:003B  GS:0000

Call stack:
Address   Frame     Logical addr  Module
7C809752  00033014  0001:00008752 C:\WINDOWS\system32\kernel32.dll
1002D7EF  00033060  0001:0002C7EF C:\Program Files\Zeus\xnet.dll


Post by Guest » Fri Jun 03, 2005 1:38 am

From the ouput trace the error reported is a call stack overflow which suggests to me Zeus has entered some sort of recursive infinite loop. But the bigger question is why is this happening :? and why can I not reproduce the same bug :?

So for me to have any chance of trying to replicate the crash I need to know a few more details. For example:
  1. In the FTP Host Section what is the host name you enter?
  2. In the FTP Host Section do you use a proxy server?
  3. In the FTP Host Section do you use a port number?
  4. In the FTP Host Section do you use an initialisation string?
  5. What are the states of the FTP Host logon, binary and write as unix options?
  6. Are you using FTP or SFTP protcol?
  7. Finally what is the file name that you enter in Save As URL dialog entry field?
Cheers Jussi

Posts: 6
Joined: Wed Jun 01, 2005 8:58 pm

Post by ntitan » Fri Jun 03, 2005 3:18 pm

1. newrunque (I have this configured in my windows hosts file to a local IP address 192.168.1.x) But I've also tried it with a dns resolvable host name.
2. No proxy server
3. I've left the port blank
4. No init string
5. [x] write as unix file, [x] Binary file transfer, [ ] prompt for logon
6. I've tried it with both ftp and sftp.

Could there be some part of the old version of Zeus overlapping with this latest install? I will uninstall/reinstall zeus and see if that helps.

Posts: 6
Joined: Wed Jun 01, 2005 8:58 pm

Post by ntitan » Fri Jun 03, 2005 4:16 pm

Sadly the uninstall/reinstall didnt work.

I'm not sure where else I should look. I just did a fresh install of windows about a week ago, and ran all available updates...

Let me know if you have any other suggestions or need more info.
And thanks again for the help Jussi.


Site Admin
Posts: 2451
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Tue Jun 07, 2005 9:52 am

To further analyse this ftp problem the following test was run:
  1. This open source ftp server was downloaded: ... e?download
  2. This directory was created: d:\temp\ftp
  3. The indiftpd.exe file was copied into this directory
  4. The server was started with this command line: indiftpd.exe -L 6
  5. The Zeus 3.94a was run
  6. A new file was created
  7. The File Save As URL menu was used to save the file to ftp://localhost/test.txt
And the good news is on this occasion Zeus did crash :)

So the lastest build of the xnet.dll was used THE TEST REPEATED and this time the file was saved just fine, producing the following FTP server trace output:
D:\temp\ftp>indiftpd.exe -L 6
07/06/2005:19:32:25;Use "indiftpd -h" for help. Exit using "Ctrl-C".
07/06/2005:19:32:25;Starting server on port 21...
07/06/2005:19:32:25;Listening for FTP connections on port 21.(108).005:19:32:46;Connection established from -> localhost
07/06/2005:19:32:46;;21;;1151;;;;220;Connected to IndiFTPD
07/06/2005:19:32:46;;21;;1151;anonymous;USER;anonymous;331;Password required for anonymous.
07/06/2005:19:32:46;;21;;1151;anonymous;PASS;;230;User anonymous logged in.
07/06/2005:19:32:46;;21;;1151;anonymous;PORT;127,0,0,1,4,128;200;PORT command successful.
07/06/2005:19:32:46;;21;;1151;anonymous;LIST;;150;Opening ASCII mode data connection for directory listing.
07/06/2005:19:32:46;;21;;1151;anonymous;LIST;;226;[Bytes: 349][Time: 0.02 s][Speed: 22.72 K/s]
07/06/2005:19:32:50;;21;;1151;anonymous;TYPE;I;200;Type is set to I.
07/06/2005:19:32:50;;21;;1151;anonymous;PORT;127,0,0,1,4,130;200;PORT command successful.
07/06/2005:19:32:50;;21;;1151;anonymous;STOR;/test.html;150;Opening BINARY mode data connection for /test.html.
07/06/2005:19:32:50;;21;;1151;anonymous;STOR;/test.html;226;[Bytes: 13][Time: 0.02 s][Speed: 0.79 K/s]
07/06/2005:19:32:50;Connection closed (108), anonymous disconnected.
So the good news is it looks like there might be something wrong with the 3.94a xNet.dll :)

To test this theory please make a backup of the xNet.dll and download this replacement dll.

Cheers Jussi

Posts: 6
Joined: Wed Jun 01, 2005 8:58 pm

Post by ntitan » Thu Jun 09, 2005 4:58 pm

That did the trick.

Thanks Jussi

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: amuzhofaxuq and 13 guests