File paths with accents don't work in the workspace

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
Post Reply
jcso01
Posts: 6
Joined: Tue Sep 14, 2004 6:55 am

File paths with accents don't work in the workspace

Post by jcso01 » Tue Apr 05, 2005 11:26 pm

Hello there:

I'm very happy working with my Zeus editor, but i have a little problem, when i add files in a project but some character in the path have accent, in the workspace showme the file with a "equis" and i can't open the file:

By example:

the file path is:
"c:\jcso\c?digo\test.java"

Greetings;)
JcSO

Guest

Post by Guest » Wed Apr 06, 2005 5:56 am

This does appear to be a bug :(

Jussi

jcso01
Posts: 6
Joined: Tue Sep 14, 2004 6:55 am

Post by jcso01 » Wed Apr 06, 2005 3:29 pm

So... this is a normal behaviour?, what if the code structure is part of an external project and i can't change this, don't have a solution :(

Greetings;)
JcSO

Guest

Post by Guest » Wed Apr 06, 2005 11:38 pm

From what I could tell the file name (which contains a unicode character) is getting converted to an ANSI string within Zeus. For example when I open the file using the File Open menu the file name (as displayed in the title bar) shows that it has been converted to an ANSI string.

But the real problem is this special ANSI conversion was added a very long time ago to fix a problem with opening files that containe OEM characters. So some more investigation is required since if this code is removed the OEM bug will return, but if it is code is left as it is then Unicode files will be broken :(

Jussi

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: No registered users and 10 guests