Zeus IDE Forum Index Zeus IDE
Use this forum to ask for help, submit a bug report or make a suggestion.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

File window does not update

 
Post new topic   Reply to topic    Zeus IDE Forum Index -> Reporting a Bug
View previous topic :: View next topic  
Author Message
jmangasarian2



Joined: 04 May 2008
Posts: 5

PostPosted: Sun May 04, 2008 5:09 pm    Post subject: File window does not update Reply with quote

I found when I installed Zeus 3.96o on WindowXP the the contents of each file that is open does not show up. It is as if the window is not being painted. I tried to refresh the screen by moving the window off the screen and back on. It does not work. I tried closing and reopening the file. It did not work. The only thing that fixes it is when I close and reopen Zeus. I saw this in two cases. First when I first installed Zeus. The second was after I tried to FTP my project.
Back to top
View user's profile Send private message
jussij
Site Admin


Joined: 13 Aug 2004
Posts: 2162

PostPosted: Mon May 05, 2008 12:08 am    Post subject: Reply with quote

Quote:
The contents of each file that is open does not show up. It is as if the window is not being painted.

When a document window stops painting it generally indicates that something unexpected (i.e an internal Zeus error) has gone wrong Sad

On a few occasions I too have seen this happen, but unfortunately I was never able to easily replicate the problem at will. I think the problem is somehow timing related, which is why it is so difficult to replicate.

The next Zeus patch adds a few more internal locks and these will hopefully eliminate this timing error.

But if you find a way to easily replicate the bug please post the details Wink

Cheers Jussi
Back to top
View user's profile Send private message Send e-mail
jussij
Site Admin


Joined: 13 Aug 2004
Posts: 2162

PostPosted: Tue May 13, 2008 12:12 am    Post subject: Reply with quote

I think this bug has been fixed in the latest Zeus release found here: http://www.zeusedit.com/forum/viewtopic.php?t=2118

Cheers Jussi
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Zeus IDE Forum Index -> Reporting a Bug All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group