Zeus IDE Forum Index Zeus IDE
Use this forum to ask for help, submit a bug report or make a suggestion.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bookmarks in Zeus 3.96 do not work

 
Post new topic   Reply to topic    Zeus IDE Forum Index -> Reporting a Bug
View previous topic :: View next topic  
Author Message
HardyPill



Joined: 09 Feb 2005
Posts: 13
Location: Germany

PostPosted: Tue Jan 16, 2007 1:01 pm    Post subject: Bookmarks in Zeus 3.96 do not work Reply with quote

I'm using the BriefEx Keyboard Mapping. In Versions up to 3.95z if I press 'Alt' + '0' I can drop a bookmark, as I can see in the Status line. With 'Alt' + 'J' '0' I can jump to the previously assigned bookmark.
With Version 3.96 this didn't work Sad . I cannot see the infromation about a dropped bookmark in the Status line, therefore I cannot say, if dropping a bookmark or jumping to a bookmark doesn't work. Anyway, if I press 'Alt' + 'J' the new bookmark dialog was opened, but there are no entries.

Please try to reproduce this and let me know, what's the problem...

Michael
Back to top
View user's profile Send private message
jussij
Site Admin


Joined: 13 Aug 2004
Posts: 2103

PostPosted: Tue Jan 16, 2007 10:00 pm    Post subject: Reply with quote

Hi Michael,

Quote:
In Versions up to 3.95z if I press 'Alt' + '0' I can drop a bookmark, as I can see in the Status line. With 'Alt' + 'J' '0' I can jump to the previously assigned bookmark.

To return to this older functionality just remap the Alt+J key to the BookMarkGoto keyboard function Wink

Quote:
Anyway, if I press 'Alt' + 'J' the new bookmark dialog was opened, but there are no entries.

I will see if I can reproduce this problem.

Cheers Jussi
Back to top
View user's profile Send private message Send e-mail
HardyPill



Joined: 09 Feb 2005
Posts: 13
Location: Germany

PostPosted: Wed Jan 17, 2007 10:40 am    Post subject: Reply with quote

Hi Jussi,

I did the old assignment for 'Alt' + 'J' and the known dialog asks for the bookmark number...
But it seems that dropping with 'Alt' + '0'/'1'/... doesn't work: If I try to goto a dropped bookmark, I get the error message in the status line: No bookmark dropped at this location.

Furthermore I hope that I can get an update to 3.96 for free because I bought the 3.95z only 3 weeks before the 3.96 was launched. Wink

Best regards
Michael
Back to top
View user's profile Send private message
jussij
Site Admin


Joined: 13 Aug 2004
Posts: 2103

PostPosted: Fri Jan 19, 2007 2:15 am    Post subject: Reply with quote

Hi Michael,
Quote:
Furthermore I hope that I can get an update to 3.96 for free because I bought the 3.95z only 3 weeks before the 3.96 was launched.

The Zeus upgrade page is now finally working Smile

For the upgrade pricing details refer to this link: http://www.zeusedit.com/forum/viewtopic.php?t=1033

Cheers Jussi
Back to top
View user's profile Send private message Send e-mail
jussij
Site Admin


Joined: 13 Aug 2004
Posts: 2103

PostPosted: Mon Jan 22, 2007 10:13 pm    Post subject: Reply with quote

The latest Zeus for Windows 3.96a patch fixes this problem Smile

Refer to this link for more details: http://www.zeusedit.com/forum/viewtopic.php?t=1035

Cheers Jussi
Back to top
View user's profile Send private message Send e-mail
HardyPill



Joined: 09 Feb 2005
Posts: 13
Location: Germany

PostPosted: Wed Jan 24, 2007 9:02 pm    Post subject: Reply with quote

Hi Jussij !

I installed the patch 3.96a - but the behaviour with the bookmarks was unchanged !!! Crying or Very sad
Please check it again !

Michael
Back to top
View user's profile Send private message
codeguy



Joined: 22 Aug 2006
Posts: 11

PostPosted: Fri Jan 26, 2007 4:20 pm    Post subject: Reply with quote

Hi Jussi,

I too am having problems with bookmarks. I have the 3.96a eval, and I copied over my old zConfig folder.

I cannot get bookmarks to work at all. I have Alt-1 mapped to DropBookmark1, but it wont drop. I have Ctrl-1 mappged to GotoBookmark1, and it reports "No bookmark set at this location".

Otherwise... Looks great!

-Andy
Back to top
View user's profile Send private message
jussij
Site Admin


Joined: 13 Aug 2004
Posts: 2103

PostPosted: Sun Jan 28, 2007 10:50 pm    Post subject: Reply with quote

Quote:
I cannot get bookmarks to work at all.

Unfortuately I can not replicate any of these issues Sad

For me the BookMarkDrop1, BookMarkDisplay and BookMarkGoto keyboard functions all seem to be working fine Confused

I did notice the bookmarks do go wrong if sections of code are folded away, but I am pretty sure this was an issue will all versions of Zeus and not just this latest version.

Cheers Jussi
Back to top
View user's profile Send private message Send e-mail
jussij
Site Admin


Joined: 13 Aug 2004
Posts: 2103

PostPosted: Wed Feb 28, 2007 10:36 pm    Post subject: Reply with quote

Bookmarks should now be working in the latest Zeus patch: http://www.zeusedit.com/forum/viewtopic.php?t=1064

Cheers Jussi
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    Zeus IDE Forum Index -> Reporting a Bug All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group