Column Select Bug in v3.96o

If reporting a bug with the Zeus editor please post the details here. Please do not post questions here.
gwgs
Posts: 78
Joined: Tue Nov 21, 2006 6:30 pm

Column Select Bug in v3.96o

Postby gwgs » Sun Apr 06, 2008 10:36 pm

When selecting a column of text using column select, if you only select vertically, you see a blank column at the selection. once you unselect the selection the text is still there correctly, it is only wrong while selected. If you select horizontally as well as vertically you get a highlighted selection box.

eg: sample text
XXXXXX
XXXXXX
XXXXXX

sample text vertically column selected at the 3rd column without any horizontal selection.
XX XXX
XX XXX
XX XXX


Thanks

Grant Smith

jussij
Site Admin
Posts: 2238
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Sun Apr 06, 2008 11:27 pm

What RGB color values do you have defined for your fourground and background marking region :?:

You can find this out by going to the Document Type, Color panel, selecting the Marked Area option, then double clicking on the color square.

In the old Zeus when you select in column mode there is no indication of an active selection. With this version Zeus will simulate a column selection by crearting a color that is close (but not identical) to the current marking colors.

What might be happening is that because of you current marking colors, this simulated color might be somehow overflowing the RGB ranages :?

You could also try altering your current marking color.

Cheers Jussi

gwgs
Posts: 78
Joined: Tue Nov 21, 2006 6:30 pm

Postby gwgs » Mon Apr 07, 2008 12:18 am

Background selected colour is white, foreground selected colour is black

Standard background colour is black, foreground colour is white.

I changed my marked text colours, and when I did the test selection, the blank line came up as an inverted marked text background colour with the marked text foreground colour unchanged.

With my normal colour selections therefore, i get black on black.

jussij
Site Admin
Posts: 2238
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Mon Apr 07, 2008 1:38 am

Could you use the schemes Save As button found in the color setup dialog and send me the resulting .col file, using the e-mail button at the bottom of this reply.

Cheers Jussi

jussij
Site Admin
Posts: 2238
Joined: Fri Aug 13, 2004 5:10 pm

Postby jussij » Tue May 13, 2008 12:13 am

This painting bug has been fixed in the latest Zeus release found here: http://www.zeusedit.com/forum/viewtopic.php?t=1863

Cheers Jussi


Return to “Reporting a Bug”

Who is online

Users browsing this forum: No registered users and 0 guests

cron