Zeus Under Linux

Find Tips and tricks on how to better use the Zeus editor. Feel free to post your own tips but please do not post bug reports, feature requests or questions here.
Post Reply
jussij
Site Admin
Posts: 2451
Joined: Fri Aug 13, 2004 5:10 pm

Zeus Under Linux

Post by jussij » Mon Apr 02, 2012 11:04 pm

Rat shows how to run Zeus under Linux using Wine: http://www.zeusedit.com/zforum/viewtopic.php?t=2627

Here are some screen shots of Zeus running on Ubuntu Linux:

Wine Desktop
Zeus Workspace
Zeus Class Browser
Zeus Autocomplete

OSX users can use WineBottler to install Wine: http://winebottler.kronenberg.org/

Cheers Jussi
Last edited by jussij on Sat Apr 05, 2014 6:01 am, edited 2 times in total.

mgag
Posts: 70
Joined: Tue Jun 24, 2008 9:09 pm

Zeus 7 Wine

Post by mgag » Wed Apr 04, 2012 3:24 pm

I recently tried with with Ubunto 10 and stock wine (i didn't try any 'tricks"). Zeus did work, but the Workspace tools did not work... I made some attempt to debug but didn't get anything useful. It seemed that the external tools that Zeus was spawning off to build workspaces simply crashed and did not return anything.

Using the tricks, does the Workspace/Projects/Tags work?

jussij
Site Admin
Posts: 2451
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Wed Apr 04, 2012 11:24 pm

I recently tried with with Ubunto 10 and stock wine (i didn't try any 'tricks"). Zeus did work, but the Workspace tools did not work...

Inspired by Rat's efforts I tried running Zeus on Ubuntu 11.10 using the standard Wine package that comes with that release.

To my surprise I found that nearly everything worked :o

The results of my efforts can be seen here: http://www.zeusedit.com/platform.html
Using the tricks
For Ubuntu 11.10 I didn't have to resort to any of these tricks.
does the Workspace/Projects/Tags work?
Yes they did, as can be seen from the workspace, class browser and autocomplete screenshots.

I spent an hour or so testing the setup and from what I found most thinks did work.

For example the latest Zeus installer includes a python26 command line interpreter.

On this Wine environment I was able to compile, run an even debug a Python script all from within Zeus.

Cheers Jussi
Last edited by jussij on Sun Apr 08, 2012 3:29 am, edited 1 time in total.

jussij
Site Admin
Posts: 2451
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Sun Apr 08, 2012 3:23 am

I did some more testing of Zeus running on Linux Ubuntu using Wine and from what I can tell nearly everthing works :)

The only two problems I found was the Quick Help did not work and for some reason you can't bind anything to the F10 keyboard key.

Wine has definitely come a long way sime the last time I tried it.

Cheers Jussi

mgag
Posts: 70
Joined: Tue Jun 24, 2008 9:09 pm

Post by mgag » Wed Apr 11, 2012 1:44 pm

I retried and can agree that almost everything works; specifically the Workspace/project/tags stuff works, which didn't work for me before. I think you need Wine v1.4 (maybe 1.3), but I don't think 1.2 works.

One slightly annoying thing, I use Brief keymappings, and when one hits ALT, there is a tendency for the UI to grab the menu, rather than process the key binding... (I am using 3.97i).

One of my python macros that I use a lot did not work. This is the one,
http://www.zeusedit.com/zforum/viewtopic.php?t=2633
I don't have time right now to try and fix it. I still think this snapshot feature would be an appreciated feature of Zeus...

jussij
Site Admin
Posts: 2451
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Sat Apr 05, 2014 5:54 am

One slightly annoying thing, I use Brief keymappings, and when one hits ALT, there is a tendency for the UI to grab the menu, rather than process the key binding... (I am using 3.97i).

I did a search of winehq.org and came across this link which suggests this might be an issue with the Linux window managers.

It also offers up this as a possible workaround:

The Clone tool uses the ALT key in a way that conflicts with many window managers. Here's how to fix that:
  • Ubuntu or Fedora: Go to System -> Preferences -> Windows, and under Movement Key, pick "Super" instead of "Alt".
  • Kubuntu: Go to the K Menu -> System Settings -> Look and Feel -> Windows, and under Movement Key, pick "Super" instead of "Alt".
  • Suse with GNOME: Go to Computer -> Control Center -> Look and Feel -> Windows, and under Movement Key, pick "Super" instead of "Alt".
  • Suse with KDE: Go to Gecko Menu -> Favorites -> Configure Desktop -> Desktop -> Window behavior -> Window Actions -> "Inner Window, Titlebar & Frame", pick "Meta" instead of "Alt".
[/i]This link also suggests this issue is caused by the window manager and offers up some more info.

Cheers Jussi

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: No registered users and 1 guest