How can I actually disable auto-indent.

Get help with the installation and running of the Zeus IDE. Please do not post bug reports or feature requests here. When in doubt post your question here.
Post Reply
jbrandwood
Posts: 11
Joined: Fri May 30, 2014 1:27 pm

How can I actually disable auto-indent.

Post by jbrandwood » Thu Nov 06, 2014 5:25 pm

I want TABs instead of SPACEs at the start of lines.

I have disabled "Tabs as spaces" (actually tried it both ways).

I have disabled everything possible on the Template properties tab.

And yet ... Zeus keeps on mixing TABs and SPACEs at the start of the line,
often with a TAB or 2, followed by SPACEs once it thinks that I'm indenting passed the start of "overhanging" code.

I've tried remapping the Enter key from "EnterSmart" to just "Enter", and while that fixes some other annoyances, this behavior persists.

How can I get Zeus to stop doing this?

jussij
Site Admin
Posts: 2429
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Thu Nov 06, 2014 10:10 pm

How can I get Zeus to stop doing this?
Use the Options, Editor Options menu to edit the keyboard mapping and change the setting for the Enter key.

It will be bound to EnterSmart so just bind it to Enter.

Cheers Jussi

jbrandwood
Posts: 11
Joined: Fri May 30, 2014 1:27 pm

Post by jbrandwood » Thu Nov 06, 2014 10:26 pm

Thanks, I'm already using "Enter" instead of "EnterSmart" ... so perhaps my problems are with "MarkPasteSmart" ... I'll switch that out next.

jussij
Site Admin
Posts: 2429
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Fri Nov 07, 2014 1:43 am

And yet ... Zeus keeps on mixing TABs and SPACEs at the start of the line
I have managed to find a case where the smart paste is not honoring the use tab setting and I think this is the cause of the issue you are seeing.

I will look to fix that issue ;)

Cheers Jussi

jussij
Site Admin
Posts: 2429
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Mon Nov 10, 2014 12:37 am

This SmartPaste issue has been fixed in the beta version found here: http://www.zeusedit.com/z300/ze32-beta.zip

With this change the SmartPaste will pad the lines based on the setting of the Tabs as spaces option found in the document type.

Cheers Jussi

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: No registered users and 4 guests