kill on debug panel hangs zeus

If reporting a bug with the Zeus IDE please post the details here. Please do not post questions here.
Post Reply
Posts: 3
Joined: Thu Nov 14, 2013 10:37 pm

kill on debug panel hangs zeus

Post by jksmithiii » Thu Nov 14, 2013 10:41 pm

Debugging golang program, set a breakpoint, did some stepping, then clicked "Kill" button on debug panel. Got a cursor wait and it didn't return from there after a couple of minutes.

Site Admin
Posts: 2499
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Thu Nov 14, 2013 11:32 pm

Thanks for the bug report. I will try an replicate the issue at this end.

Site Admin
Posts: 2499
Joined: Fri Aug 13, 2004 5:10 pm

Post by jussij » Thu Nov 14, 2013 11:52 pm

I tried to replicate this but for me the Kill command is working fine :?

Could you try the following:
  1. Use the Options, Editor Options menu and in the General section set the Document Display Mode to Create tiled.
  2. Close all but one simple Go file that you will be debugging
  3. Run the debugger, Step a few commands and then hit the Kill button
You should now see the debugger output produced by the Kill command.

When I do this I see the following output in the debugger output window:
(gdb) kill
Kill the program being debugged? (y or n) [answered Y; input not from terminal]
As shown above the debugger knows it is in terminal mode so it does not wait for use input. In your case I suspect what might be happening is the debugger is waiting for the user input.

If this is the case it should show up in the debugger output window.

There is also one other thing worth trying:
  1. Start the debugger
  2. In the Zeus Debugger Control panel Command Line field enter this command.

    Code: Select all

    set interactive-mode off
By issuing that command you will have told the debugger to not prompt for user input.

Cheers Jussi

Post Reply
kuchnie warszawa opinie

Who is online

Users browsing this forum: Bing [Bot] and 1 guest